A Place For Gamers By Gamers

You are not connected. Please login or register

View previous topic View next topic Go down  Message [Page 1 of 1]



Well, the title pretty much says it all. Previously you needed to either be on 3.55, or Linux via OtherOS to toggle QA on/off, but Thanks to Smhabib you can now easily do it on 4.21+.
Habib Toolbox with QA Toggle is available below, along with the QA Toggle standalone source code for those wishing to learn from it or port/build it for other purposes/versions.
Okay, Smhabib has been pretty busy lately, lets go over some of the details.
Habib Toolbox 1.02.02 was recently released, and I was a little preoccupied with some things yesterday so I’m sorry if I’m late on anything. Something I hadn’t specifically mentioned but I had briefly listed with the download links at the bottom of the page, is that currently Habib Toolbox is only built for 4.65. There was a little confusion about that in the forums, but it’s only meant for 4.65 Cobra CFWs.
With his Toolbox release, Smhabib also released the source code he used to toggle the QA Token in Habib Toolbox. He specified that the method would work with 4.21+, but that the code might need to be adjusted. I guess this is where some of the confusion was, I should have been more specific with my original draft of this article. To be fair though, all of this was outlined in the release notes below and discussed within the forums.
Now, apparently there was a bug with Habib Toolbox 1.02.01 preventing the console from being QA Flagged if it hadn’t previously been flagged before. With the release of Habib Toolbox 1.02.02, this was rectified.
Also with this update Smhabib has provided us with a QA Toggle pkg for 4.21+ (links below).
Before updating this article, I decided to give it a go on my Rogero 4.46 Cobra and it worked superbly.
My system had already been QA flagged; I ran Habib’s 4.21+ QA Toggler, the screen went black for maybe 20seconds and then returned to XMB. I tested the QA button combo, and the QA Token was indeed removed/disabled.
I ran QA Toggle again, there was another brief black screen and I was returned to XMB. This time when I did the QA button combo, the Debug Menu returned.
Smhabib’s Announcement:
since 4.xx(prolly 3.56+) sony protected the qa thing with ecdsa and we cant access it through UM in the gameos(preventing token from being written)
so i just started once to look around qa.i was able to do it on 3.55 but not on 4.xx.
now what i did to make that working was that i accessed HV scm through dm using VUART(packet id=0x900C) and wrote the token.this can be done from linux easily but we want from gameos right?
sooooo I SUCCEEDED!!!
this has been ported to habib toolbox and is bumped to v1.02.01 with many new features:
1.lv1 dump
2.lv2 swap from dev_flash or usb000
3.toggle qa
now i also made a standalone version with UGLY UNCLEANED SOURCE with all the **** i have tried past this week almost
standalone version can be easily updated by updating around 7 offsets(6 lv1 and 1 lv2 for hvsc redirect)

Download Link

happy studying and using!!!!
1.main.c offsets
2.lv1_hvcall.c offset(lv2)
this has been tested on 2 consoles and so far no problem is there BUT we dont make any guarantees
this works on 4.65 but can be ported easily
UPDATE #1: Download Link

FW INDEPENDANT!!!!!!(unless sony makes GREAT changes)
on a “non supported fw” it takes 20 seconds to qa
tested on 4.65 cobra/non-cobra and 4.60 cfw
if for some reason it doesnt work on some fw then it requires porting offsets.
and its for 4.21+ cfw only
how lucky i am to have syscall 11
UPDATE #2:frown:2014-10-13)
ITS FOR 4.65 ONLY!!!!!

Download Link

toolbox 1.02.02
src for standalone is in there
changelog for toolbox:
1,fixed token writing of qa
2.fsm toggle is in there for you(normal 3.55 diag can be used to exit)
changelog for standalone:
1.fixed token writing for qa
p.s i might make this fw independant in future
do note that toolbox is for habib 4.65 cobra toggle version and any 4.65 cobra edition
UPDATE: Download Link

its now fw independant for 4.21+
for any reason if this doesnt work with the upcoming releases, porting is required
tested on 4.65 and 4.60

View user profile http://www.team-psn.net

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum

Share URL

URL Direct